Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Pasting into post not working
#1
In the MyBB forum that I am moving away from my users select a block of cells in Excel and paste it into a forum post, simply using Ctrl-C and Ctrl-V. The result is an unformatted text list. In my CreateMyBB forum editor this behaviour results in a formatted block which when posted changes to hundreds of text characters tagged with [img] [/img]. Actually it was working a few days ago.

How it should work:
Excel cells copied with ctrl-c: 
[Image: 6Eql4ro.png]
Pasted into old forum editor with ctrl-v. Note, it's become a plain text list:
[Image: CwHWJmx.png]
But here's the same pasted into the CreateMyBB forum editor - note formatting:
[Image: HXyQb7Z.png]
And then after posting it. Note the image tags:
[Image: wSbLPx4.png]
Any help will be much appreciated  Shy

What I've tried:
I turned off bbcode which worked, but this also disabled [img], [b], etc which I need.
Reply
#2
The data in the image tag looks like a png file that is copied?
Please don't PM me for support. Try to post a topic allows other people to learn.
[Image: sig-jon.png]
Like CreateMyBB? Support me at https://www.patreon.com/vbgamer45/
Reply
#3
Try clicking on the "view source" button (last button on the row) before pasting in the Excel cells.
Reply
#4
(10-06-2019, 07:59 PM)Jon Wrote: The data  in the image tag looks like a png file that is copied?

No, its just three numbers in three cells in a spreadsheet, copied and pasted, no images involved. I just did the same on the old forum and it still works there. When I first registered on your site it worked here too.

Edit: as a "proof" that it wasn't a png I pasted it between tags, it pastes text correctly. Then I deleted the php tags and the correct text remains there. Can't ask my users to do that though Big Grin
Reply
#5
(10-07-2019, 02:33 AM)liondog72 Wrote: Try clicking on the "view source" button (last button on the row) before pasting in the Excel cells.

Thanks liondog, although that works it's not something I could rely on my users doing each time.
Reply
#6
(10-07-2019, 09:01 AM)tartist Wrote:
(10-07-2019, 02:33 AM)liondog72 Wrote: Try clicking on the "view source" button (last button on the row) before pasting in the Excel cells.

Thanks liondog, although that works it's not something I could rely on my users doing each time.

For the time being you could go into Admin CP > The users account settings > check "Put the editor in source mode by default" > Save settings. Or you could get them to do the same themselves via their user CP.
Reply
#7
(10-07-2019, 10:08 AM)liondog72 Wrote:
(10-07-2019, 09:01 AM)tartist Wrote:
(10-07-2019, 02:33 AM)liondog72 Wrote: Try clicking on the "view source" button (last button on the row) before pasting in the Excel cells.

Thanks liondog, although that works it's not something I could rely on my users doing each time.

For the time being you could go into Admin CP > The users account settings > check "Put the editor in source mode by default" > Save settings. Or you could get them to do the same themselves via their user CP.

liondog, you are a gem. That's just what I need, at least until some genius can find a way of making it the default. Thanks!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)